2.1. System requirements

Minimum:

  • Chrome, FireFox, Safari, and Microsoft Edge are officially supported. 
  • Any system that can run one of the above web browsers.

 

This page was: Helpful | Not Helpful